Suggested helper for troubleshooting Microsoft Teams workflows?

New to InsightConnect/Teams - working on workflow “Lookup Top Remediations with InsightVM from Microsoft Teams” & it continues to fail with “No asset with hostname found”.
Is there a log that might offer a possible solution?
Thank you!

Is it failing on the InsightVM step, or is it making it through the decision point and returning a Teams message stating it cannot find the asset in IVM? I will take a look at the workflow and see if I can figure out what the issue might be.

Hi Michael, thank you for your help!
From the logs & Teams it does make it through the decision point - “No asset with hostname was found”.
I did modify the following yesterday to “test” -

Extract Argument: (2nd step)

  • edited and selected - “Return Multiple Matches”, Case-Insensitive(already selected). This worked but produced more results than I expected. I was able to download an output file with some data, but the job seemed to be running too long so I canceled the job.

I’ve turned this option off and we’re back to the original settings.

Running a few tests on this right now, I will let you know when I have a solution.

Updated version of the workflow, this should work for you now. Rapid7 Extensions

Thanks Michael! Trying now - will update shortly.

Outstanding! That solved it. Just curious; is there a log file we could check to solve these issues?

We have another Teams workflow (Disable/Enable User in Active Directory from Microsoft Teams) that is having errors/not working - “User was not found”.

1 Like

You can check the logs in the workflow itself, or you can log onto the orchestrator and look at the logs on the orchestrator directly.
Screen Shot 2023-03-08 at 6.03.28 PM

Orchestrator Command Line Help