SNOW Plugin Fails To Create Fields Correctly

I am getting it to create a new INC but the data is not populating.

input for Create Data:


This worked for me… is the user you are using mapped correctly in SNOW, ours isn’t in our Test env so the caller and the default group assigned.

“create_data”: {
“contact_type”: “monitoring”,
“description”: “test\nthis”,
“short_description”: “Test Demo from SOAR”,
“state”: “New”,
“urgency”: 3

“$success”: true,
“filtered_incident”: {
“active”: “true”,
“caller”: “”,
“description”: “test\nthis”,
“number”: “INC0016936”,
“short_description”: “Test Demo from SOAR”,
“state”: “1”,
“urgency”: “3”


@hayden_redd Just ran a couple of actions in our lab and it appears that the payload you’ve provided will end up creating an incident; however, if you look at the default “Incidents” page in ServiceNow it is likely being filtered by caller and this incident wouldn’t yet have a caller assigned to it. One quick way to test this is by removing the “caller” filter and show all incidents:
Screen Shot 2021-01-22 at 8.11.08 AM

In addition, you could define the caller_id as part of the payload data which is preferred by ServiceNow. In the example I show below, you can provide the string for the caller however keep in mind if there are multiple “Jane Does” ServiceNow won’t know which sys_id to use. To be safe you could assign the sys_id of the user in the ServiceNow environment as the value for caller_id:
Screen Shot 2021-01-22 at 8.13.06 AM

The input I used is:

{"description":"test from InsightConnect","caller_id":"System Administrator"}

With the first incident in this list being created:
Screen Shot 2021-01-22 at 8.09.36 AM

Hope this helps!


I can set caller_id it looks like, but can’t set description or any other fields when creating an INC.

@hayden_redd Are you not able to set the fields because of permissions (and get an error creating the incident) or do you simply just not see them in the ServiceNow UI?

the create incident action works with a success, the fields just simply dont show in the UI and they are all empty when I do a Read incident action for those same fields…

Just out of curiosity, I see you are passing variables to the description. Is it possible you are sending an invalid character? what happens if you just set description to “test”?

updated: this fails to populate any of the fields, although it does create a ticket and assign it it a group by default.

“assigned_to”:“Hayden Redd”

What version of the Plugin are you using? I’m on 4.1.0 and you can see that my example did create and populate the fields. I upgraded to 4.1.2 and it still worked. I just did a Create Incident with these fields then did a Read Incident using the returned system_id and they were all there

4.1.2 :frowning:

There must be something with the permissions in SNOW.
Only thing I could think of would be to take the Plug-in out of the picture to test.
If this PowerShell works, then i’m lost; if it doesn’t then it isn’t the plugin

$SNOW_Base_URL = 'https://<SNOW Endpoint>'
$SNOW_API_Route = '/api/now/'
$SNOW_Incident_Table = 'incident'
$SNOW_Table_URL = "$($SNOW_Base_URL)$($SNOW_API_Route)table/"
$SNOW_Incident_URL = "$($SNOW_Table_URL)$($SNOW_Incident_Table)"

$SNOW_Headers = @{
    Authorization = "Basic $([System.Convert]::ToBase64String([System.Text.Encoding]::ASCII.GetBytes("<SNOW UserName>:<SNOW Password>")))"

$SNOW_Create_Incident_Data = [pscustomobject]@{
    description = “test”
    assigned_to = “Hayden Redd”
$SNOW_Create_Incident = (Invoke-RestMethod -Uri $SNOW_Incident_URL -Headers $SNOW_Headers -ContentType 'application/json' -Method Post -Body ($SNOW_Create_Incident_Data | ConvertTo-Json)).result

$SNOW_Incident = (Invoke-RestMethod -Uri "$($SNOW_Incident_URL)/$($SNOW_Create_Incident.sys_id)" -Headers $SNOW_Headers).result

Make sure you replace:

  • <SNOW Endpoint>
  • <SNOW UserName>
  • <SNOW Password>
1 Like

the fix was to get the required sn_incident_write role. The snow plugin can fill all the fields now.