SMB Connection keeps getting reset by peer

I cannot get a successful SMB connection to a share on a windows Server.
I confirmed the settings on the share are correct for the credentials I am using.
I don’t have a firewall separating these, and no logs of attempts.
The error I keep getting is
Error connecting to SMB endpoint: [Errno 104] Connection reset by peer
I have tried every combination of settings that I can think of. Any one else run into this?

Digging into the code on GitHub and I think this might be trying to use SMBv1 and we have that disabled. Can anyone confirm if this is true fro this plugin?

According to the in the repo, the plugin uses the pysmb dependency. Pysmd does support smbv2,

You’d have to set the use_ntlmv2 boolean=true for smbv2 to successfully authenticate. If it fails, the search the Doman controller logs for that user name and make sure it really is trying ntlm2 for the authentication protocol.


Thank you, I misunderstood what that meant.
Still not working and I don’t have any logs for this attempt anywhere, that is what is baffling me.
I even confirmed with netcat that the port was accessible from my orchestrator.
Looking at the docker logs, everything looks correct for the connection attempt.

No prob, if you own the smb share try fiddling with a few settings like client side caching or smb signing. If you’re not worried about who can see what’s on it, you could add the Everyone group to have modify permissions just to verify it works at all. I have seen at least one app fail when client side caching is disabled.

I just disabled DirectoryCacheLifetime, but some other people are running jobs at the moment so I need to wait on the reboot.
I’ll mark this as answered if that works