Service Now

Having a tough time getting the SNOW plugin to work.

Just wanting to read an open incident.

Tried using Search CI but it wants something called a table?

Tried using Read Incident but it returns empty every time, every filter I throw in.

Search CI
table=wat?
query=number=INC#
+correct sys id

Read INC

filtering_fields:{
“description”:“test”
}
+correct sys id

In SNOW the CMDB is split up into “tables” that you need to define when looking at it, e.g. cmdb_ci, change_request, incident, ect.

For Incidents, use incident

here is a list of all the tables you can choose from: https://docs.servicenow.com/bundle/london-platform-administration/page/administer/reference-pages/reference/r_TablesAndClasses.html

Edit:
Also, There is an Action “Read Incident” that takes the system_id as an input and allows you to choose the fields you want to see, e.g. number,state,active,description,short_description,caller,urgency

@hayden_redd as Brandon mentioned, we do have a Read Incident that can be used to lookup an incident by sys_id and return fields as defined in the comma separated list. Below is an example configuration I used in one of our environments to confirm:
Screen Shot 2021-01-14 at 9.00.12 AM

In this case, I was only returning short_description; however, if multiple fields are wanted then it would be a comma separated list such as short_description, description, sys_id, assignment_group.

If you don’t already know the sys_id of the incident, you can also use the Search Incident action which will return a list of sys ids that match the filter. Filtering can get a little tricky but all that is documented here: https://docs.servicenow.com/bundle/paris-platform-user-interface/page/use/common-ui-elements/reference/r_OpAvailableFiltersQueries.html. I used something like short_descriptionISNOTEMPTY to return all incidents that have a short description defined.

Output of those two actions together then looks like:
Screen Shot 2021-01-14 at 8.59.53 AM

If you are already trying the Read Incident action, I would check to make sure the description is actually defined for the incident you are retrieving. When a field is defined that isn’t populated for the incident, the response should show that field as empty like below:
Screen Shot 2021-01-14 at 9.07.12 AM

1 Like