Scope and Conditions in Goals and SLAs not working properly

Hello together,

I have a weird problem with “Goals and SLAs” on InsightVM.
I created a continious Goal with the following scope and condition:

Scope: asset.sites IN [‘scg’]
Condition: Remediate 100% of assets to achieve !( ~> ‘kaspersky’)

After initialization the Goal says it´s 49% compliant (749 assets compliant and 787 assets not compliant), but that´s not the truth:

  1. There are only 750 assets in site SCG (not 1536)
  2. Only 3 assets have the specified software installed

How can I fix the query and build continious goals to check compliance against unistallation of specific software?

I also tried this as a “Remediation project”, but then I get more than one solution which isn´t helping at all.

Goal is to populate a Dashboard with simple graphs telling the compliance about software.

Thanks for any help and input.

Best regards

Nobody any suggestions?

Apologies for the delay here! If you go to the query builder and do a query that has the same scope, eg asset.sites IN [‘scg’], do you see the correct number of assets listed there?

And under the “Build Goal” section of your goal where you configure the type, did you select “Remediate vulnerabilities” or “Configure assets”? What do your queries look like there? That should make this a little easier to understand.

Hi Holly,

thanks for taking your time and investigate.

Yes, if I use the scope in the query builder I get the correct number of assets.

In the “Build Goal” section I select “Configure assets”. It´s also shows the correct number of assets there, but after deploying the Goal, the number gets wonky.

This is the final result:

Best regards

1 Like

Thanks for the patience here. I’ve confirmed with a team member that your setup with the scope + condition you shared looks correct. One question - did your team change consoles around early to mid January? I ask because when we took a look at this on the backend, it looked like there might be extra assets included here that are potentially from an “old” console. That could explain the larger numbers and provide a path forward for clearing those assets and getting the correct number in this goal.

Hi Holly,

thanks for your investigation. I don´t know anything about a change regarding our console. Is there a way I can check that?

Best regards

So in this case, to double check the console status and get to the bottom of the goals issue you’re seeing, I think it would be best to open a ticket with our Support team. They’ll be able to get a better look into your environment than we can here on the forum and help figure out why you’re seeing those extra assets. They can also determine if there were indeed any changes regarding your console that could be contributing to this.

You can open a ticket here:

Appreciate your patience here, and thanks for the info you shared to help us get started with troubleshooting!

Hi Holly,

thanks for your time. I just created a ticket as mentioned.

I will get back here after the ticket is solved to give a feedback.

Best regards

Hi Holly,

support fixed it. :+1: We had some duplicate assets in the background.

Thanks for the time and effort.

Best regards