Problem with specific Teamviewer API call from workflow


I’m trying to create a workflow to pull data via the Teamviewer API but am getting an error that I can’t get to the bottom of. The Teamviewer API details can be found here and can be tested on the page if you have valid token.

My call to the EventLogging request is failing. This API request requires two parameters, StartDate and EndDate. Whatever I try, I’m getting an error 3 which is a reproducible error by testing on the webpage linked above by deliberately entering an invalid date. Entering an invalid parameter name results in a a different error, so i’m sure the error is something to do with the formatting of the date as being passed by the workflow step. I’ve tried manually entering the dates, copy pasting from the Teamviewer page after testing and storing\retrieving the values as Global Artifacts and using those (which I’m doing with the API token so i know that works).

The input into the step looks correct. I’ve tried using Body (any) as opposed the Body Object but that makes no difference

Object (4)
body_any :
EndDate : 2024-05-10T00:00:00Z
StartDate : 2024-05-01T00:00:00Z
Authorization : Bearer xxxxxxxxxxxxxxxxxx
route : /api/v1/EventLogging

Does anybody know what I could be getting wrong here? I’ve used similar processes in other workflows for other API but this one is beating me at the moment!