Old plugin version still running after upgrading workflow

After uploading a new version of a custom plugin, workflows continue to use the old container. (Errors are caused by code that no longer exists, error messages contain the previous plugin version id)

Is there a way to clean up old containers or force the update?

Things I’ve tried

  • Upgrading the plugin in the workflow and applying changes (expected fix)
  • Creating a new workflow that uses the newest version (still runs old version even though new version is selected)
  • Uploading a new version of the plugin ( 0.1.5 had bugs, fixed in 0.1.6 but it doesn’t run, added a comment and uploaded 0.1.7)

Workflow Run

New Workflow, selected 1.6

If it’s a custom plugin, you’ll have to remove it and re-add it to the workflow. InsightConnect sees that as a new plugin.

The easiest way, I think, is to click on the step in the WF, go to the configure screen on the right, hit previous until you’re at the plugin selection screen, then pick the plugin and configure it.

I’m also going to pass this on to our internal team to see if we can do something with it. I agree that’s not a great user experience.

1 Like

Did that. Created a whole new workflow; still doesn’t pick up the new version. :slight_smile:

When you get back to the Action screen are you seeing something like this?


Note the vendor is a custom vendor here.

If you haven’t changed the vendor, I don’t think the custom plugin will work. We only allow rapid7 (as vendor) (and some special cases) to be uploaded as a custom plugin.

Another thing you can look for: did your custom plugin actually make it in. If you go to Settings > Plugins & Tools, look to see if you see your plugin. For example…here we have the Official office 365 plugin, and an email security plugin I was testing:



1 Like

None of those. Turns out, something is going on with my icon-plug-in setup… it’s packaging the old container with the new version info when I do make && icon-plugin export

(So, not a bug in the platform, and although I don’t know what I did, it’s probably not ICON’s fault)

Did you forget to regen after making changes to the spec?

icon-plugin generate python --regenerate

Yea. I ended up doing a docker system prune -a to clear out all my old containers and it finally worked. I would have saved myself a ton of time if I had actually tried testing locally first :frowning:

I think this was a “Domko broke his dev environment” problem and not an ICON problem. (But thank you for all the troubleshooting ideas, and sorry for crying wolf)