Issuing commands from Teams unsuccessful

I’ve tried setting up multiple Teams workflows and posting events to the Teams channel is successful. However, commands issued from the Teams channel are not starting jobs. What step am I missing here?

1 Like

I remember when I set this up originally I was told that this could happen if not all the permissions were set up correctly.
This plugin uses two sets of credentials, username/password and an App Registration.
I think Posting uses one set and Reading uses the other.
Also, double check your regex using in your Trigger to make sure you are filtering correctly.
For all my read commands I start with a ! to make sure they don’t accidentally get triggered, so your regex should start with ^!


I’m officially stuck on this one. I’ve reviewed the application and user accounts settings provided; however, the commands entered to the channel are not picked up by the orchestrator. Are there any additional permissions required by the Azure app, group or, user?

Hi Donald, I have a feeling the issue is with the regex you are using for the Teams trigger. Can you please post what you are using for the trigger command as well as an example of what you have been sending in Teams?

Not sure if this is still an issue, but have you tried changing the channel name?

I was having an issue where nothing was working in Teams.

Turns out the problem was my Team name. If anyone in your org already has a Team named whatever you are naming yours (TEST was mine) it will attempt to connect to the oldest Team with that name.

Try a randomized Team name and a specific Channel name in your workflow.

1 Like

First, thanks to the folks that responded and tried to help. I’ve discovered a few things while testing and I hope this helps the next person:

  • The permissions required for the application built in Azure are going to vary due to what you’re trying to accomplish. Verify your app permissions!
  • The Teams service account must be Azure only using
  • The Teams channel should be private.
  • The commands are case sensitive.
  • Execute your trigger commands via “New Conversation” not “Reply”.
  • Be aware that human decisions will take the user outside of Teams to ICON.

I agree with this except for two points:

  1. I’m using an on-prem AD account that is synced with Azure without an issue.
  2. I prefix all my regex with (?i) to make the commands more user friendly and I make multiple word commands have an optional underscore so !terminateUser !TerminateUser and !terminate_user are all valid with (?i)!Terminate_?User[ ]
1 Like