Installed with the "latest" engine, still displayed as an outdated version

I received notification yesterday via email from R7 appsec engines are no longer usable, and must be installed with a newer engine for on prem engines. I followed the instructions and download a new engine installer. I noticed the engine version is the exact same as the engines I had installed on my VMs. I tried downloading the installer from different locations as the instructions mention, and they are all the same version. I believe R7 forgot to include their latest version OR the latest version is not working as it should (its displayed as outdated once the VM and Cloud are paired).

Need some feedback on this, please and thank you.

1 Like

24 hours post install in my environment and I’m seeing the same thing. The console says the server is not on the latest version. Auto-Update is enabled.

Hey I got a response back from support:

“That is a display error on the version. You can safely ignore it and we will be fixing it. You should be good to go.”

TLDR, as long as you have the latest they should resolve this later.

I ran a test scan after the install and I’m still able to run scans from my VMs.


I found the same thing over two years ago and reported it. The issue is that the updater does not update the registry keys from the installation. I did request a bug report be raised to fix this.

In my case, Windows Defender was reporting outdated software despite the agents and engines being at the latest version. My hack was to update the registry entries to the version currently installed.