HTTP Plugin Post Request for Connection

Does HTTP Plugin support POST requests while creating a new connection? When I try to create a new connection with the plugin, it throws an error Invalid username or password provided. Verify your username and password are correct.


I have validated the credentials, and they are correct. It works fine from a Postman only if it is a POST request, not when it is a GET request.

Use postman to generate a CURL command for the POST you want to do and use it to verify you have all the correct information in the headers. If it works in postman, my guess is you’re missing something from the headers. I think HTTP POSTs from InsightConnect are JSON by default, so if you’re including Content-Type: application/json in your header you should remove it and see if it works.

I tried the request from Postman and even tried from the terminal using curl, both worked fine. But when tried as a connection request from the plugin, it still shows the same error. The same request, if I do GET in Postman, I don’t get any response.

Based on the error message from the plugin, I wonder if the HTTP Plugin connection only supports GET requests.

It defiantly works with POST, I use it prolifically in my workflows for passing data to inbound webhooks and other APIs. I’ve attached a screenshot of what the log shows when it’s successful. It’s hard to troubleshoot anymore without knowing what app you’re attempting to POST to. I’m sure you’ve noticed that the log output from python included in the failed jobs stinks and does very little to assist with debugging. Some apps require the credentials to be encoded, some require a token to be included in the URL or header to verify the sender. I’m guessing you’re sending the credentials in the correct format if CURL works, so it must be missing something critical in the header or routing information. If you’re willing to tell me what app you’re trying to POST to, I can look at the documentation and see if I can spot anything.

Annotation 2023-05-23 192548