Default Headers (CUSTOM_SECRET_INPUT) Not Passing Through

Hi all,
I have a workflow that uses the HTTP Request plugin.
I have setup the Connection and added in the credentials with the CUSTOM_SECRET_INPUT attribute in Default Headers.
When i test the workflow that uses the connection, it doesnt pass anything through in the headers, the headers are blank.
I left the Headers in the workflow blank. I have even tried to copy the default headers into this field too.
Any idea where im going wrong?

You will need to update your plugin version to 6.0.4 as there was a fix introduced with that update to resolve this issue.

Hi Eric,
Have updated, but still not playing ball.
I think it doesnt like it that i have it in this format:
{"Authorization":"ApiToken CUSTOM_SECRET_INPUT"}.
I think if i dropped the “ApiToken” part, then it would work, or seems to with other Connections.
Is there a limitation that the VALUE should ONLY contain the “CUSTOM_SECRET_INPUT”?
Getting this error, but works if i put the header in manually in the above format.

It should work as is. I suggest submitting a support case so that this can be raised to the dev team.

Yeah can ignore, i re-created the Step in the workflow and seems to work now!