CMDB integration errors

We successfully set up the CMDB integration a little over a year ago specifically to use the tagging feature and it was working great. Then in November the jobs all failed. We haven’t been able to get it working since. We’ve tried a lot of things, but the most recent thing we tried was blowing away the old integration and rebuilding it. That failed also with the error: asset_tagging integration failed to run: {“message”.“An error occurred executing the REST request for Rapid7 VM endpoint /api/3/reports, method:post, error:{}”}
Has anyone else had similar issues?

We recently had the integration set-up and we ran it only few times but without errors.

It’s possible that this could be happening due to connectivity issues, either between ServiceNow and the MID server, or between the MID server and the InsightVM console. There are a few things you could do to further troubleshoot this.

You may have already done this, but it’s good to verify that the InsightVM credentials you’re using for the integration are correct and have the required permissions. This section of the ServiceNow CMDB doc talks about the permissions needed and the overall connection setup.

Another thing to confirm is that the MID server is able to communicate with the console. Once you confirm that the MID server is up and running with no status issues, log onto it (via SSH, for instance) and open a terminal window. You can then try executing a curl command that sends a request to the VM console and see if you get a proper 200 response. Here’s a possible example command (it’s got some placeholders, and you might have to fiddle with it a bit):

curl --location --request GET 'https://<CONSOLE_HOST>:<CONSOLE_PORT>/api/3/sites?page=0&size=10' \
--header 'Accept: application/json;charset=UTF-8' \
--header 'Content-Type: application/json' \

If the response you get is a 200, then connectivity between the MID server and the console should be good to go. If not, then the MID server can’t connect and the integration won’t be able to run. In that case, you could double check to see if there are any proxies or firewalls between the MID server and the console.

If you’re still having trouble pinpointing the issue, you could also enable debug logging. This will log the request and response bodies for outgoing requests made by ServiceNow, so it could help you see if there are any other connection-related errors. We’ve got some instructions on how to enable debug logging here:

We do recommend disabling this logging once it’s no longer needed, since it can be verbose and show sensitive values in the requests that are logged.

I hope this helps you narrow things down, at least. For future reference, I’d be interested in hearing if you do find this to be a connectivity issue, or something else entirely.