Anyone ever used rapid7/Typo Squatter

Anyone ever used the plugin rapid7/Typo Squatter?
I tried with the default and I’m getting an error with the input

rapid7/Typo Squatter:1.0.1. Step name: check_for_squatters
Running command: ./dnstwist/ --json > /tmp/tmpoXlkKj/results.json
No JSON object could be decoded

I opened a support ticket, but i also wanted to check here in case I’m doing something stupid

Nah I don’t think you are doing something stupid. It seems that this plugin is installing the latest dnstwist script.
The latest version doesn’t support the --json parameter. Maybe it did in the past, but it would now be something like --format json .
I tried to clone the plugin and fix it but also ran into issues with Pythonv2 and a non-existing entropy Python module.
Hope support can sort things out on this plugin.

Thanks for reporting this issue. We will have the team look into it.

Thanks, 01486282

I use it in a workflow. I can only get “Score domain” to work. I can’t get the “Check for Squatters” option to work.

Hello Some_Rando!

We actually are looking into this plugin. Feel free to open a support case for tracking, otherwise, we’ll keep you posted regarding updates for this plugin!


1 Like

Thank you. I’ll check in here!

This plugin has been updated. Please retest with the latest version.



Confirmed working, thank you

1 Like

Hey @some_rando! This plugin has been updated very recently. Can we have you update your workflow’s usages of the plugins and re-attempt to leverage the typo squatter plugin?

Please let us know if you have any luck!


Hi Hyron. I will definitely update and check it out. Thank you!

1 Like

@hyron_harrison Works like a charm, thank you!

1 Like