Authenticated vuln scans for ESX

What I understand is that it is possible to perform authenticated vulns scans for ESX versions prior to 6.0, but not newer ones.
Did I understand correctly ?
Is there any chance that this gets changed soon ?
Thanks.